• Welcome to iHelpForum - the place to get help from knowledgeable techs in all areas of Tech, Home and Auto help. Consider checking out our Guides or Registering an account to post on our forums today.

Solved Attempting to get an external Hard Drive to work for storage

Presiding Cat

Well-Known Member
I have a used 500 GB external hard drive that I've been trying to use under Linux mint 18 1... I'm locked out of it for some reason. I can not drag and drop files into it, The "create folder" option is grayed out on the File menu. Why can't I write to it!?

Forum copy.png

I've goggled my fingers sore, but still have no idea what I need to do to get it working...
Last edited:

Presiding Cat

Well-Known Member
Can you read the files on the drive Presiding Cat? I am assuming that the drive was setup on another computer. If that is the case the you need to take ownership of the drive.
I first deleted the existing partition... Then...
In gparted I clicked on Device>and Created a Partition Table.
Next I created a new partition on sdb by going to Partition and selecting the ext4 partition...
This was done in Linux 18 1...

Blank Page.png

There are no files on the Drive LC.
Last edited:

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
WCG Team Member
Aye, Try this from the Community.MintLinux.com site.

How To Change ownership of External USB Drive
USB drives formatted with FAT file system don't have such ownership issues, but once I've formatted my USB drive with ext4, and noticed that it's ownership changed to "root", as a result, I was not able to write anything to that device! I was frustrated, but found a solution that I am going to tell here as such thing could also happen when you format any USB drive with ext2.

  • First, open your terminal, and then type "sudo NameOfYourFileManager" (for example, in KDE, type "sudo dolphin"), press "enter", give your sudo password. This will open your file manager with root privilege.
  • Go to that device, right click and select "properties" from the drop down menu, then click the permission tab and you are there! Change the permission and ownership the way you want, close the window, you're done!
Sounds easy? It is. Try this, Good luck!

Presiding Cat

Well-Known Member
Not sure how accurate this is but this is supposed to be the file managers for the different flavors of Mint Linux

Mate: caja
Cinnamon: nemo
xfce: thunar
KDE: dolphin
You might want to recheck that mate... The Version is Cinnamon...

The cinnamon version is 4.4.0-53- Generic
Last edited:


Linux user
iHF Regular
Hello Presiding Cat,

Terminal commands are case sensitive, So for example, Your trying to start your file manager from the terminal, The file manager for Mint Cinnamon is Nemo, However to start it from a terminal you need to type in "nemo", All lower case letters, Hence it didn't work before, Because you typed it in with a capital "N". Try that same command again except this time with all lower case letters, Like so:

sudo nemo
That should start your file manager. Then you can follow the steps as posted by LC in post 5.


Oh and one last thing, "4.4.0-53- Generic" is the version of the Linux kernel your currently running, Not the version of Cinnamon. ;)

Presiding Cat

Well-Known Member
Thank you all for your replies... The following information Worked...
When you created the partition you also created a label for the partition which has spaces in the label name, namely "500 GB Storage". When the bash shell encounters spaces like that it stops and tries to run the command on a file named "/media/marz/500" which does not exist. It's generally a better practice to not put spaces in partition labels for this reason. You can workaround it by running:


sudo chmod 777 /media/marz/500\ GB\ Storage/
Try that and see if it runs.